Upload and Download not working

Tried to upload a file to my server and all it does is spit out the curl line each time. I am running Catalina 10.15.3. I looked at your troubleshooting but that isn't an issue I don't use .bashrc. Here is what it does, BTW your .bashrc_Core_Shell is present as well as the line in .bash_profile. Also the download is greyed out even if I highlight a file???

andy@server-2 ~ % curl -fsSL https://raw.githubusercontent.com/codinn/core-shell-scripts/master/bashrc_Core_Shell -o ~/.bashrc_Core_Shell && . ~/.bashrc_Core_Shell && grep -qs ".bashrc_Core_Shell" ~/.bash_profile || echo $'\n[[ -n "$SSH_TTY" || -n "$SSH_CONNECTION" ]] && [ -r "$HOME/.bashrc_Core_Shell" ] && . "$HOME/.bashrc_Core_Shell"' >> ~/.bash_profile

Hi Andy, could you please run this command in Core Shell:

echo $PROMPT_COMMAND

and tell me the result?

Thanks,

echo $PROMPT_COMMAND

update_coreshell_cwd

It's a sign that .bashrc_Core_Shell was loaded properly, but update_coreshell_cwd didn't report current working directory properly.

Could you please run:

echo $TMUX
echo $BASH_VERSION

And could you please also try running the Core Shell working directory extension directly?

update_coreshell_cwd

Then check whether the download menu still greyed out.

Thanks,

Going from Mac to Mac Catalina. The variables don’t exist for macOS but do for Linux.

macOS:

andy@macsrv-2 ~ % echo $TMUX

echo $BASH_VERSION

andy@macsrv-2 ~ % update_coreshell_cwd

update_coreshell_cwd:11: unrecognized modifier `i’

andy@macsrv-2 ~ % bash --version

GNU bash, version 3.2.57(1)-release (x86_64-apple-darwin19)

Copyright (C) 2007 Free Software Foundation, Inc.

RedHat 8:

Ok we are good. I tested on red-hot worked fine. Catalina changed to zsh and I changed my session to bash but the $SHELL was still using zsh since I didn’t logout or reinitiate my session, thanks. Make a blurb on your side about the Catalina and zsh in case someone runs into it. thanks Andy

1 Like

Andy, thanks a lot for the information and the remind, I'm going to add zsh support in next update.

Yang

Its a nice tool, I have always used aliases for my repetitive ssh takes but this keeps it nice and tidy, thanks Andy