Upload / Download not working


  • MacBook Pro 16 (2019) Intel
  • MacOS Monterey [12.2.1 (21D62)]
  • Core Shell [Premium — Version: 3.6.2 (Release Date: 2021-12-08)]
  • "bash" command is being executed on SSH connection
  • "Set locale environment variables on connecting" — unchecked

Upload / Download not working.

I've already tried

  • installing beta builds of Core Shell Application,
  • also tried reinstalling the helper tool.
  • Checked if helper tools is enabled or not (ENABLED).

Log files are always like this:

2022/02/20 13:27:13:798  ––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––
2022/02/20 13:27:13:798  Equivalent Command: sftp -v -o RemoteCommand=bash -o ServerAliveInterval=15 -o ServerAliveCountMax=3 -o ExitOnForwardFailure=yes -o ControlMaster=no -P 1022 USER@HOST:
2022/02/20 13:27:13:799  Using Core Helper 6.6 (r3386)
2022/02/20 13:27:13:823  OpenSSH_8.8p1, OpenSSL 1.1.1l  24 Aug 2021
2022/02/20 13:27:13:823  debug1: Reading configuration data /Users/lilac/.ssh/config
2022/02/20 13:27:13:823  debug1: Reading configuration data /etc/ssh/ssh_config
2022/02/20 13:27:13:823  debug1: /etc/ssh/ssh_config line 21: include /etc/ssh/ssh_config.d/* matched no files
2022/02/20 13:27:13:823  debug1: /etc/ssh/ssh_config line 54: Applying options for *
2022/02/20 13:27:13:823  Cannot execute command-line and remote command.

I've carefuly followed this thread but still not working: Upload and Download not working

  • echo $PROMPT_COMMAND gives nothing on new SSH session to the same server
  • echo $PROMPT_COMMAND gives update_coreshell_cwd if done right after executing "Enable quick upload"

Any ideas?

Thank you very much for detailed information.

Could you please try clear the RemoteCommand in advanced options? it seemed the remote complain bash command not found.

If you still could not get it to work, please enable logging and send me a desensitized log?

Kindly Regards,


Thank you Yang! It work when I removed remote bash execution.

But I'm still curious of such a behaviour.

But thank You anyway!

You have to specify full path of the command, that is bash, usually at /bin/bash.

Kindly Regards,