CryptorRSA.CryptorRSA.Error error 1

Hello, I have this error when I try to connect using RSA.

" Equivalent Command: ssh -i "/Users/[ removed ]/Library/Group Containers/[ removed ]" -o ExitOnForwardFailure=yes -o ServerAliveInterval=15 -o ServerAliveCountMax=3 -o CheckHostIP=yes -o ConnectTimeout=15 [ removed ]@[ removed ]
13:01:20 Connecting…
13:01:20 Using Embeded Helper 6.0 (r3257)
13:01:20 Authenticating…
13:01:21 The operation couldn\200\231t be completed. (CryptorRSA.CryptorRSA.Error error 1.)
13:01:21 Abnormal Disconnect"

If I use the Equivalent command in the console, the access works without any issue.

Hello Cristian, could you please enable DEBUG3 logging and send desensitized log?




I have the same error starting today or yesterday.

This is the Debug3 log:

sorry I have to send Droplr link to the text as the discussion forum won't let me upload "more than 2 links" as a new user (not sure what it is considering "links")

thank you

@felasfa thank you very much for the debug log. Are you using a M1 Mac? Could you please install and enable Core Helper then try again?


PS: is this issue always reproducible?


I have multiple tunnels. All are showing the same error and none are working. I’ve restarted the app many times, the computer and the router with which it establish the tunnel. All was working fine until yesterday (or the day before, I’m not sure) and nothing is working now.

I'm sorry about the issue :frowning:

I'll send you a hot-fix binary via personal message ASAP.

We have public released hot-fix versions for the CryptorRSA problem:

@felasfa thank you very much for the detailed log and verifying the hot-fix beta :heart: