SSH Proxy errors after upgrading to MacOS Ventura

After upgrading to MacOS Ventura, I could not use SSH Proxy anymore. I found those below errors from Console log:

Oct 27 01:58:26 JanMac SSH Proxy[3908]: socketDidDisconnect error: <SSHKitDynamicBridgeConnection:0x600000508a00 host:localhost port:22> Error Domain=NSPOSIXErrorDomain Code=61 "Connection refused" UserInfo={NSLocalizedDescription=Connection refused, NSLocalizedFailureReason=Error in connect() function}

Oct 27 02:11:34 JanMac SSH Proxy[4647]: socketDidDisconnect error: <SSHKitDynamicBridgeConnection:0x600002080140 host:localhost port:22> (null)

Could you help to fix? SSH Proxy is something I use everyday. Thanks.

1 Like

Are you connecting to your Mac? Please make you have enable Remote Login in System Preferences -> Sharing.

Kindly Regards,

Yang

Yes. I have enabled SSH in my local system.

I tried SSH to both local and remote system but still have that error after upgrading to MacOS Ventura.

Could you please try Core Tunnel? It provides SOCKS proxy as SSH Proxy.

After installation, please refer to Dynamic Port Forwarding section of this topic:

And get to know how to use the proxy:

Kindly Regards,

Yang

I tried Core Tunnel but it could not replace SSH Proxy, because it doesn't have traffic routing (blacklist, whitelist).

Hi,
Phil, did you find a fix for this ? I too need the whitelist/blacklist functionality. As you say "Core Tunnel" doesn't have this functionality unfortunately. And "SSH Proxy" doesn't appear to work on Ventura.

Any suggestions of apps that provide something similar ?

Thanks

D

I also encountered this problem

same problem hope it can be solved in future

1 Like

Same issue here. I've tried to make the switch to CoreTunnel, but it seems to have issues that for whatever reason SSHProxy does not when used by clients that support only "HTTP Proxy"? Postman in particular is a problem for me, it works fine via SSHProxy but gets a "Socket Hangup" when pointed to Core Tunnel ...

Fwiw, I see the issue is that SSH Proxy is getting an exception back when trying to open the dialog to accept new host keys. I don't see a way to update these keys manually either, as they are stored in a binary format it the SSH proxy preferences plist... It'd be nice if codinn would either fix this bug or possibly opensource the tool so someone else might?

1 Like

Same problem here and I don't know when will be an update available for precious ssh proxy app!

Funnily enough, what seems to have helped me is the much reviled Touch Bar. I changed the authentication from Public Key to Password. I then hit connect and saw the terms "Trust" and "No" appear on the Touch Bar. Obviously, I went for Trust knowing fully well for which application the prompt was generated for. Then I change the auth to Public Key and registered the private key of the proxy server. All went well and I am back in business :slight_smile:
Hopefully, this helps someone since I have been literally pulling my hair trying to resolve this for last 4 months!

Finally I was able to find a work-around when the developers cannot fix the simple UI issue :joy:

Here are the steps:

  • Install the app TouchĂ© so you can simulate the Touch Bar: TouchĂ© - Touch bar for Everyone
  • Using SSH Proxy normally. When connecting to the new server, it will ask you to trust the new server in the Touch Bar (in order to add that server to the app's known_hosts)
  • Click on Trust, and voila. Now it works!

Tested on Macos Ventura and MacOS Sonoma. I only wish that Mr. Yang can spend just a little time to fix this UI issue so we don't have to do this workaround, and build a Apple Silicon build. Or just open-source it, we will fix it for you.

1 Like