Problems connecting after update 2.2

Hello guys!

After the update to version 2.2, the core shell and core-tunnel stop working and present the following message

Equivalent Command: ssh -o ExitOnForwardFailure=yes -o ServerAliveInterval=15 -o ServerAliveCountMax=3 -p 45045

22:45:52 Connecting…

22:45:52 Using Embeded Helper 4.6 (r46)

22:45:52 Authenticating…

22:45:53 Unable to negotiate with port 45045: no matching key exchange method found. Their offer: diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1

22:45:53 Abnormal Disconnect

22:45:53 Connection failed, retry after 3s…

22:45:55 Disconnected

I tried to install Core Helper in version 4.6 but it has an error. according to the print

I use mac in version 10.15.5



Hi Erik, here is a very similar report:

Could you please check that report and give the solution a try?



Hello, I redeemed as sudo and managed to install as the print.
However, when trying to activate Core Helper informs that I need to install the add-on.

Erik, I never install Core Helper via sudo, and generally we should avoid to do this for security reasons.

I would recommend you uninstall Core Helper then install it as a non-privileged user.

As the conclusion in this topic:

The problem is very like caused by the owner of ~/Library/LaunchAgents was changed to root accidentally.

Some app may change the owner of ~/Library/LaunchAgents to root, a safer solution is change it back to the current login user.



I tried to carry out the information given in the indicated topic, but I got the same error.

Erik, could you please execute these three commands, and paste the output?

ls -la ~/Library/ | grep LaunchAgents
ls -la ~/Library/LaunchAgents/
ls -la ~/Library/Group\ Containers/

BTW, could you please also try this command in local Terminal?

ssh -o -vvv ExitOnForwardFailure=yes -o ServerAliveInterval=15 -o ServerAliveCountMax=3 -p 45045



Hello, follow the print with the executed commands.

After a few attempts, I managed to install Core Helper.

I enabled the same but the connection error continued.

I ran the command:

ssh -o -vvv ExitOnForwardFailure = yes -o ServerAliveInterval = 15 -o ServerAliveCountMax = 3 -p 45045
However, it failed because it did not recognize the parameter - vvv

or execute the same command without the -vvv parameter I was successful in connecting via terminal

I found it strange that even after installation, no files were created in the / Library / LaunchAgents / folder for the core helper

Core Helper agent configuration was installed to ~/Library/LaunchAgents/, not /Library/LaunchAgents/

Well, I think I've found the problem: the codebase of OpenSSH shipped by Core Shell has been upgraded to version 8.3, the diffie-hellman-group*-sha1 algorithms were deprecated and disabled by default.

Please edit your profile settings, and set HostKeyAlgorithms to +diffie-hellman-group1-sha1:


As requested I made the changes but still without success in the connection

Oh, my bad, I'm sorry, you should set KexAlgorithms directive to +diffie-hellman-group1-sha1, not HostKeyAlgorithms.

1 Like

good evening!

Made the change as requested, and it worked.
I succeeded in my connection.

I appreciate the support to solve the problem

1 Like

Happy to help :smiley: