Please update OpenSSH or allow external ssh binary

I am trying to use Yubikey managed keys (ed25519_sk with touch) but openssh fails with "start_helper: helper "/usr/libexec/ssh-sk-helper" unusable: No such file or directory" when it should prompt for the touch.
As far as I understand, this could be fixed, if it would use the OpenSSH version installed with homebrew (because the native macos openssh does not support these keys either currently) or if the integrated OpenSSH version would be upgraded to v9.3.

Invoke ssh-sk-helper requires Core Helper install for access system resource, please try install and enable Core Helper.

Kindly Regards,


I have Core Helper installed. it does not work.

"/usr/libexec/ssh-sk-helper" does not exist on macOS 13.4.1 with Apple silicon, the included ssh version (9.0p1) does not come with it.

the only way to get it is to install OpenSSH with homebrew, but homebrew puts it to "/opt/homebrew/Cellar/openssh/9.3p2/libexec/ssh-sk-helper".

I tried to set the "PATH" env var with Core Helper to "/opt/homebrew/Cellar/openssh/9.3p2/libexec" but it did not work. also it would break for every openssh update, because this path contains the openssh version.

Also, macOS does not allow me to write to "/usr/libexec", so I cannot easily put it there


I got it working by setting the env var "SSH_SK_HELPER" to "/opt/homebrew/Cellar/openssh/9.3p2/libexec/ssh-sk-helper" with Core Helper.

but this is still not ideal, I need to roll this out to 50+ users and the path will change with each OpenSSH update