I get a permissions error when adding a new key to a connection

I get this error message when I try and add a new key to a connection through core shell.

"abc.pem" couldn’t be copied because you don’t have permission to access “privatekey”

I have full permissions on the ~/.ssh/privatekey folder:
drwxrwx--- 18 ME staff 576 Jun 1 10:03 privatekey/

Even if I manually copy the key file into the directory, I get the same error when I select it in Core Shell.

Please help! Thanks!

The only way I am able to get around it is the following:

  1. delete the key from the .ssh/privatekey folder
  2. Edit the coreshell profile and set privatekey to disable
  3. save profile
  4. Edit profile and select key again.
    Then it works.

That workaround doesn't always work.

I am trying another profile and it isn't working.

Hi Michael,

Could you please enable logging (DEBUG3) and paste the debug log?

BTW, do you have Core Helper installed?


I can, but my problem isn't when I try and connect to a host. The problem is when I am trying to save an existing profile with a new key (Connections tab, Private key field).

Additional info:
This is a profile that was duplicated from another profile. I need to change the key that it uses for authentication.
No other changes are made in the settings.
The key file (ABCD.pem) I am trying to select already exists in the ~/.ssh/privatekey/ folder.

This is the error I get in the popup error window:
"“ABCD.pem” couldn’t be copied because you don’t have permission to access “privatekey”.
To view or change permissions, select the item in the Finder and choose File > Get Info."

I have R/W permissions on the folder ~/.ssh/privatekey/
I have R/W permissions on this key file ~/.ssh/privatekey/ABCD.pem

Hi Michael, thank you for clarification, I'm sorry for misunderstood you. Could you please try create a new folder with a different name, move ABCD.pem to the new folder and import it from Private Key field again? What happens may provide a hint.

BTW, could you please also try import the key from Preferences… > Identity, the imported private keys are saved in directory ~/Library/Group\ Containers/E78WKS7W4U.io.coressh.ssh/.ssh/privatekey/

Kindly Regards,