Getting "Operation not permitted" on Connect


(Tony Hart) #1

I haven't used Core Tunnel for a few weeks, but it was working perfectly before, now I get the following error on Connect.

load pubkey "/Users/thart/.ssh/id_rsa": Operation not permitted

However if I run "Equivalent Command" below from a terminal it connects without problem.


Equivalent Command: ssh -NT -L 4003:192.168.1.103:22 -L 4005:10.11.12.103:2222 -L 4006:10.11.12.106:2222 -o ExitOnForwardFailure=yes -p 5001 support@10.20.38.222

05:41:48 Connecting…

05:41:48 Using Embeded Helper 4.0 (r40)

05:41:48 load pubkey "/Users/thart/.ssh/id_rsa": Operation not permitted

05:41:48 Authenticating…

05:41:48 @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@

05:41:48 @ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @

05:41:48 @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@

05:41:48 IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!

05:41:48 Someone could be eavesdropping on you right now (man-in-the-middle attack)!

05:41:48 It is also possible that a host key has just been changed.

05:41:48 The fingerprint for the ECDSA key sent by the remote host is

SHA256:8d3vqHBMBNyPXMpOvyV1uugdtyq3zjXN1cqm49AnA18.

05:41:48 Abnormal Disconnect


(Yang.Y) #2

If your tunnel connects normally, you can ignore this error message, it's harmless. OpenSSH always tries to read ~/.ssh/id_rsa for identity, but Core Tunnel is sandboxed and have no privilege to access any of your files without explicit permission.

If you would like Core Tunnel loads your identities in ~/.ssh/ automatically, you can just enable Core Helper:


(Tony Hart) #3

Thanks for your help. Enabling Core Helper fixed the problem, without it I could not connect. Did something change recently, as I said it was working fine before.

thanks!


(Yang.Y) #4

Glad to help :slightly_smiling_face: