(CryptorRSA.CryptorRSA.Error error 1.)


I am still getting "(CryptorRSA.CryptorRSA.Error error 1.) " even after the update 3.0.1, But "Beta version downloaded directly" works fine. is there any extra step involved. everything used to work before this recent update. Thanks

What's your version of macOS? And could you please try rest the SMC of your Mac:

  • For Mac with Apple Silicon, shut down your computer, wait 5 minutes, then power on the computer.
  • For other Mac computers, see the Apple Support article How to reset the SMC of your Mac.

Please let me know if you still face this issue after reset the SMC.


macOS Big Sur version 11.5
MacBook Pro 15-inch

Thank you for the info, is it possible for you to upgrade to macOS 11.5.1?

The beta shares same codebase with 3.0.1. From the information I've received so far, this error occurs in macOS 11.5, but not macOS 11.5.1.


Hello Yang

  1. updated to 11.5.2
  2. Reset SMC.

still same issue. beta works fine, "3.0.1" from App Store does not.


This is a very tricky problem, I investigate it and try to figure out whether it is caused by app or a fault of macOS.

Please download and use following betas before we fixed CryptorRSA problem eventually:

Download Core Shell 3.0.1 Beta »
Download Core Tunnel 3.0.1 Beta »

You can import profiles from App Store version to Beta version with simple steps:

Thank you again for reporting the issue.


Hi @yang I have the same issue here. Even after installing Core Shell 3.0.1 with the Hot Fix I still get the error about CryptorRSA.CryptorRSA.Error error 1.

I have tried the Beta version downloaded from the links above and it works fine. It is the official release the one failing.

I can provide full stack trace if required.

We are working on this issue, will make a beta release soon.



1 Like

@zenisca @AlterSys we just released Core Shell 3.5 Beta, and invited you join our Beta Program.

I believe CryptorRSA error is fixed in this beta, could you please download the beta binary and give it a try?

Thanks a lot,


The Core Shell 3.5 Beta works. It connects with no issue to a server that fails when using the Core Shell 3.0.1

1 Like