Adding Fonts to CoreShell? (Powerline Support)


I'm trying to figure out if it's possible to add additional fonts to CoreShell. Under Preferences --> Font --> [Change] there is a pre-defined list.

I'm trying to SSH into a server that's set up to use the Powerline shell, which expects to have a font available with custom symbols. Without that, I just get a bunch of question marks.

I've tested the custom font I want to use via iTerm2, and it works as it should. I just can't figure out how to get it into CoreShell. (And I very much want to get it into CoreShell...iTerm2 is far too complicated. :stuck_out_tongue: )

Am I missing something obvious?

It's not a predefined list, Core Shell list all fonts you installed in your Mac. I use Powerline fonts for quite some time.

Download Powerline fonts and execute in the package, then restart Core Shell, the Powerline fonts should be listed in Core Shell font panel.

Kindly Regards,



Thanks for your reply. :slight_smile:

I was very surprised to realize I should be seeing all installed fonts in Core Shell. Mine has always looked like this:

I had assumed it might because I've installed via Setapp.

Before I try to install the Powerline fonts (thanks for the tip on how to do that, btw!), I wanted to make sure my existing font list is as it should be.

Thanks again for all your work and support on this project.

Forgot to mention: Core Shell filters system installed fonts that suitable for terminal or programming, that is, the fixed pitch fonts.

This may misleading you see it as a predefined list :smiley:

Kindly Regards,


Thanks for the extra info.

I'd previously used Font Book to install the patched version of Meslo from the link you provided, before I posted this thread, just to see if it would work. iTerm sees it, but CoreShell doesn't.

I barely know how to use Font Book since I open it about once a year, so I'm thinking I need to remove the font I installed and use the method you indicated. :slight_smile: I'm curious why it didn't get picked up from Font Book, though. I assume I did something wrong; I'm just not sure what.

EDIT: The shell script worked perfectly. :smiley: Though, if I'm honest, I'm now more than a little distracted by the realization that Font Book doesn't work the way I thought it did--or possibly at all. ¯_(ツ)_/¯

1 Like

I didn't know that fonts installed by Font Book is not visible for Core Shell, thanks a lot for telling.

I'll do some tests and try to find out what's going on. Also, the Powerline fonts are planed to embed into Core Shell in next release, as long as there are no license issues.

Thanks for doing further testing on this.

I had to install a different patched version of the Meslo font for powerlevel10k (a ZSH theme), and Core Shell saw that without issue after being installed via Font Book. I did have to quit and restart Core Shell to get it to pick up the Powerlevel font.

I may have just bungled installing the Powerline fonts via Font Book, or something else could have glitched. Everything worked as you said it should with the Powerlevel font.

I'm really glad to hear the Powerline fonts are getting embedded into the next version of Core Shell. My favorite Terminal emulator keeps getting better. :slight_smile:

Core Shell 3 embeds a part of Powerline fonts.

While I were dealing with Powerline fonts, I noticed that not all Powerline fonts were patched properly. For example, Meslo Slashed for Powerline and Terminus for Powerline could not recognized by Core Shell, since they lack fixed-width font attribute.

This may be the main reason why you didn't see some installed fonts in Core Shell.

Another thing worth to mention, Core Shell won't refresh the installed font list for you, so you may have to relaunch Core Shell after installing new fonts.

I'd like to keep this topic open, improve the font loading mechanism in future releases.

Thank you very much for helping.



Thanks for the follow up message explaining how the fonts work (or in some cases, don’t work).

I had some server-side issues with Powerline and didn’t have time to debug them, so I ended up switching to Powerlevel10k (a ZSH/Oh-My-ZSH theme), which uses its own glyphs and custom font.

Next time I bring up a fresh Linux install (which should be fairly soon), I’ll try a fresh install of Powerline and test the embedded Core Shell Powerline font with that. :slight_smile:

Thanks again for all your work on this.

  • JTD.
1 Like

Any updates on this? I would like to switch from iTerm to Core Shell but I need the fonts working. I have no issue with iTerm, ohmyzsh with POWERLINE10K work fine.


Core Shell supports Powerline fonts since version 3.0:

Which zsh theme are you using? Could you please send me a copy of your customized zsh configuration, so that I can reproduce it?

Thank you,


Thank you for the reply. Please let me know what file or files you would like. I had previously upgraded from 9K to 10K, perhaps there are known issues with upgrading.

I am using Core Shell 3.5.2.

If you didn't modify system default config files of zsh or oh-my-zsh, then ~/.zshrc should be enough.

Thank you,


I did not modify any config files. Other than some simple aliases I installed omz and P10K and configure per instructions. Here is my .zshrc, thank you for taking a look.

.zshrc_for_codinn (4.2 KB)

@fastzombies sorry to have waited a long time. Powerlevel10k requires Nerd Fonts

Powerlevel10k doesn't require custom fonts but can take advantage of them if they are available. It works well with Nerd Fonts, Source Code Pro, Font Awesome, Powerline, and even the default system fonts. The full choice of style options is available only when using Nerd Fonts.

Since Nerd fonts are actually supersets of Powerline fonts, we decided to embed Nerd fonts in version 3.6 instead of Powerline fonts. And we've made it happen in 3.6 beta 2

I've invited you join our Beta Program. Could you please download the 3.6 beta 2 binary and give it a try?

Thanks a lot,


No problem, thanks for the acknowledgement for beta release contribution. Looks like the icons are all fixed up. The weirdness you see is some artifact of resizing the window, but it goes away. Looking forward to the next release.

Is this happen in local terminal? I did a quick test on both local terminal and remote ssh session, resizing works as expected, the command prompt seemed fine.

Could you please run stty -a before and after resize window? I'd like to compare the results.

Thank you,


Yes, local terminal. I cannot reproduce this, omz had just updated itself as you can see and perhaps that was a factor. The prompt properly resizes with window now. I will purchase a license for next release. Thank you.

1 Like