Warning: remote host identification has changed


(Andrea Cogliati) #1

Core Shell doesn’t let me connect to a host anymore with the message “WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!” I’m sure that I’m connecting to the correct host. How do I remove the old key so I can connect?


WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!
(Yang.Y) #2

The remote side might has changed its identity, could you please set log level to Debug3 and paste the log here?


(Andrea Cogliati) #3

It’s possible that the computer is using the same IP address of an older host. Here’s the log (I anonymized hostnames and IP addresses):

09:13:47 ----------------------------------------
09:13:47 Equivalent Command: ssh -tt -F “/Users/andreac/Library/Group Containers/E78WKS7W4U.io.coressh.ssh/.ssh/config” -vvv -o ServerAliveInterval=15 -o ConnectTimeout=15 -o CheckHostIP=yes -o ServerAliveCountMax=3 -o ExitOnForwardFailure=yes -p 82 andreac@curiosity.*.com
09:13:47 Connecting…
09:13:47 OpenSSH_7.9p1, OpenSSL 1.0.2q 20 Nov 2018
09:13:47 debug1: Reading configuration data /Users/andreac/Library/Group Containers/E78WKS7W4U.io.coressh.ssh/.ssh/config
09:13:47 debug1: /Users/andreac/Library/Group Containers/E78WKS7W4U.io.coressh.ssh/.ssh/config line 7: Applying options for *
09:13:47 debug2: resolving “curiosity.***.com” port 8122
09:13:47 debug2: ssh_connect_direct
09:13:47 debug1: Connecting to curiosity.***.com [64.***.***.46] port **22.
09:13:47 debug2: fd 5 setting O_NONBLOCK
09:13:47 debug1: fd 5 clearing O_NONBLOCK
09:13:47 debug1: Connection established.
09:13:47 debug3: timeout: 14983 ms remain after connect
09:13:47 load pubkey “/Users/andreac/.ssh/id_rsa”: Operation not permitted
09:13:47 debug1: identity file /Users/andreac/.ssh/id_rsa type -1
09:13:47 debug1: identity file /Users/andreac/.ssh/id_rsa-cert type -1
09:13:47 debug1: identity file /Users/andreac/.ssh/id_dsa type -1
09:13:47 debug1: identity file /Users/andreac/.ssh/id_dsa-cert type -1
09:13:47 debug1: identity file /Users/andreac/.ssh/id_ecdsa type -1
09:13:47 debug1: identity file /Users/andreac/.ssh/id_ecdsa-cert type -1
09:13:48 debug1: identity file /Users/andreac/.ssh/id_ed25519 type -1
09:13:48 debug1: identity file /Users/andreac/.ssh/id_ed25519-cert type -1
09:13:48 Abnormal Disconnect


(Yang.Y) #4

Could you please enable system default ssh_config andknown_hosts` configurations and try again?

If you still not in luck, please execute the command in terminal and send back the output:

ssh -vvv -o CheckHostIP=yes -p 8122 **@curiosity.**.com

(Andrea Cogliati) #5

I just removed the host entry from the know_hosts file, and now I can connect again. Thanks for pointing me in the right direction.


(Andrea Cogliati) #6

BTW, I seem to remember that SSH Shell would just display a warning but let me proceed in the same circumstance. Is it possible to configure Core Shell to do the same?


(Yang.Y) #7

It depends, if both host ip and identity were changed, Core Shell would consider it’s not safe to accept the key and continue connecting.