Used Import but did not work

I exported from SSH Tunnel and then imported, and tried to connect, and it failed. (permission denied - public key)

I have a public key - not a private key. This is not really my deep capability - why I used your tool - so was expecting seemless migration between your two products.

Ok, so now what do I do?

Firstly, you must import the key, the file you have used in SSH Tunnel:

Then, in tunnel's settings, force the tunnel use the imported key:

I am baffled, it is the same key - works in the SSH Tunne, but not with Core Tunnel. I did everything you said.

Could you please set the Log Level to DEBUG3 and paste the connection log here?

Equivalent Command: ssh -T -N -F “/Users/bwenzlau/Library/Group Containers/” -i “/Users/bwenzlau/Library/Group Containers/” -L local:22: -o ExitOnForwardFailure=yes ubunto@

20:27:12 Connecting…

20:27:12 Privileged ports can only be forwarded by root.

20:27:12 Abnormal Disconnect

20:27:12 Connection failed, retry after 3s…

Could you please send me a screenshot of the host in SSH Tunnel? It seems your configuration was not migrated correctly.

Please change the host settings in Core Tunnel according to the screenshot:

I now get this. Again this works fine with SSH Tunnel

  1. Please upgrade Core Tunnel to latest version (1.3.4), it seems you use an older version
  2. Delete this file: /Users/yang/Library/Group Containers/
  3. Change local to localhost in the screenshot:

How do you upgrade - not intuitive (no upgrade button). No website etc.

You can follow this article to upgrade apps in your Mac:

got it! deleted the old record (in the app) and created new.

Good to know that :smiley:

A post was split to a new topic: How to add ssh options -T -N into resulting command