Upload to Folder does not work with double-click on filename

When I upload a file to a folder, I use this workflow...

  1. Make sure permissions are correct for the file to be received. Sometimes this involves changing the folder permissions, sometimes creating an empty file with the same name and assigning the right chmod value.
  2. Click with two fingers on the Core Shell window for this connection, choose "Upload to "
  3. Navigate to the required local file in the Finder window, click the filename.
  4. Most apps will accept a file selected in this way for action if you double-click on the file, but Core Shell (silently) closes the Finder window but does not upload the file. If I click "Upload" after selecting the file it uploads fine (silently, sadly).

Thanks for a great product, keep safe.


I did a quick test with double-clicking on the file, Core Shell upload file as expected. There is no upload cutscenes while an uploading is triggered, could it be got overlooked?


Hi Yang.

I use this feature a lot and it's certainly not reliable - perhaps due to having to give the file selector the focus before clicking. Could it not be made active after it is spawned, I wonder?

Keep safe.

Does this issue always reproducible?

I tried with your steps again, and still could not reproduce it. Could you please record a screencast if you have a moment? May be I misunderstand your steps.


1 Like

Ah - replaying my workflow I understand now. If I have been using a different app on a different screen and right-click in Core Shell without clicking it first (to give the app the focus), it allows me to choose Upload to .... and shows the file chooser, but I cannot double-click it until I have clicked it first. My Devtendo video illustrating this will not upload because it is too big.

Thanks for the speedy reply - keep safe.

I tried your replaying steps but on same screen, double click the file in Open file dialog activate the Core Shell, and the Open file dialog still on screen.

The Open file dialog actually not controlled by Core Shell, instead, the system Powerbox take control from the sandboxed app (e.g. Core Shell).

When you invoke an Open or Save dialog from your sandboxed app, the window that appears is presented not by AppKit but by Powerbox. Using Powerbox is automatic when you adopt App Sandbox—it requires no code change from the pre-sandbox version of your app. Accessory panels that you’ve implemented for opening or saving are faithfully rendered and used.

So it sounds like an issue of Powerbox. As a workaround, we can activate Core Shell programmatically before Powerbox presents Open file dialog, but I'm not sure whether this behavior could come with side effects.


Thanks, Yang - appreciate you taking the time to look into this, and glad you could reproduce it. I share your concern about tampering as it might affect other users. For my workflow, my other Feature Request solves the problem... I'll close this one.

Keep safe.