Unable to quit Core Shell

I am using Big Sur 11.0.1 (20B29) with Core Shell 2.6.

When I try to quit Core Shell it hangs - almost as if it is trying to do something in the background. The only way I can get out is to Force Quit.

I also see the Download icon in the dock bounce for a moment whenever I upload a file to a server from the MacBook. I don't know if these events are connected.

Keep safe, Jonathan

PS I just noticed it is making an error sound when I press Cmd-Q. I closed all other apps and there is no warning message or anything. All connections are closed and I only have the Profiles window open.The Quit Core Shell menu option is greyed out as shown in the attached screenshot.

Jonathan, are you able to reproduce it? And could please select "Report" button once macOS prompts you report a problem for a Force Quit action. And, send me the the text of report problem dialog directly should help me a lot.

Kindly Regards,


Hi Yang.
It happens every evening when I have been using Core Shell all day. I was unable to reproduce the problem this morning.
I found this evening that, even with the Profiles window closed, the app will still not shut down. Force Quit did not produce the Apple diagnostic dialog.
I have been unable to find any logs for the app - if you advise where they live perhaps I could send you them?
One thing that is also different (as well as Big Sur) - this computer was new a couple of weeks ago...
Kind regards - keep safe. Jonathan

this computer was new a couple of weeks ago

Is that a Apple Silicon computer?


Sadly not :frowning:

Keep safe, JG

Are you able to quit Core Shell from Dock menu?

Does the stop responding for a couple of seconds when the Quit menu grayed?


Hi Yang.
No, I can't quit from the Dock.
Yes - it does freeze for a couple of seconds before Quit grays - you are on to something!
Keep safe, enjoy the weekend.

It could be the same issue as this one:

Do you have iCloud sync enabled? Could you please temporarily disable the Sync?

Kindly Regards,



Today I didn’t spend normal time using Core Shell but seems like the situation cleared disabling iCloud sync.

Tomorrow I will continue testing and let you know



Thank you very much Alberto, I wait for the follow-up report.

Sorry for the delay - very busy. No, I have Folder sync enabled to a local folder.

Kind regards, keep safe,


Hi, sorry to hijack but i have the same issue.
Happened first on Catalina, then upgraded to Big Sur and issue remains.

Any more light to shed on this?

You are more than welcome to join in, @skullbock . No change here - I still have to terminate Core Shell every evening and it is really frustrating.

Keep safe.


Thanks @jonathangroves

@yang any more things i can share to help you debug this?

So glad it's not just me!

@jonathangroves @skullbock I'm sorry about the issue. I tried reproduce this issue several times, but without success.

And after investigate the relevant code, it's very like caused by sync function, disable sync should fixed the problem.


It looks like it's fixed with Sync disabled. I'll let you know if it occurs again. Hoping you'll fix Sync...
Keep safe!

1 Like

Thank you for the update, will try to fix this problem in next release.


1 Like

Thanks, Yang. Keep safe...

@yang i confirm that moving from "Folder Sync" to "None" does the trick.