Back to Codinn

SVN+HTTPS over localforward failing


#1

So I migrated my config over from Shimo and unfortunately my SVN connection to an internal server will not work anymore. My connection goes through two jump hosts, the first just a localforward of 22 to the second server which forwards :443.

Using the Core Tunnel connection when trying to do a ‘svn update’ I get the following error:
svn: E170013: Unable to connect to a repository at URL ‘https://localhost:3443/svn/
svn: E000061: Error running context: Connection refused

Using openssl I checked the SSL information and for both Shimo and Core Tunnel the certificate information on localhost:3443 matches. I can also browse to over HTTPS, just can’t access the repository over svn.

Any ideas?


(Yang.Y) #2

Could you please paste a screenshot of your tunnel’s port forwarding settings? And, how do you tell the svn using the port forwarding? Full svn command would helpful.


#3

Here is the first jump host settings:

Here are the second jump host settings:

The command used to setup svn initially was (which doesn’t work over Core Tunnel):
svn check https://localhost:30443/svn/

Once the svn repository is setup as long as the tunnel is up it is normal svn commands (i.e. svn commit, svn update, etc.). However when it’s up using Core Tunnel issuing the command
$ svn status --show-updates
gives this error
svn: E170013: Unable to connect to a repository at URL 'https://localhost:30443/svn/

When the tunnel is up with Shimo the same command immediately prompts me for my svn password.


#4

OKAY… this is weird. I’d double checked everything, stopped/started the tunnels, restart Core Tunnel and nothing was working.

Took those screenshots and it’s working now, wth!

Well thanks for answering quickly!


(Yang.Y) #5

Good news :slight_smile:

And a recommendation: use Proxy Jump option will simplify your settings, and would make things easier to troubleshoot problem. The local forwarding localhost:25000 -> 192.168.0.16:22 can be replaced with this:


#6

Unfortunately though the configuration my screenshot pictured would work with the ProxyJump command my complete config wouldn’t. JumpHostA also is configured with a dynamic forward for a SOCKS proxy.