Ssh_config not being read


(Josh Batchelor) #1

Just installed Core Shell (Premium) Version: 1.6.1 also installed Core Helper. When I go into Preferences > Locations and change the ssh_config to System nothing happens. I have tried restarting the app etc. I've also tried using the default location and copying the contents of my ssh_config into it but that also doesn't work.


(Yang.Y) #2

Sorry about the problem, could you please enable the debug logging, and paste the log here?

Thanks.


(Josh Batchelor) #3

Thanks, I don't have Core Tunnel installed and I don't see a connections tab in Core Shell Settings. Am I missing something?


(Yang.Y) #4

I just updated the post and added steps to find the option, please check it again, thanks.


(Josh Batchelor) #6

Thanks, I'm not seeing an errors in the log related to reading ssh/config.


(Yang.Y) #7

Could you please share your ssh_config file, and take screenshoots of your host settings? This can help me identify the problem.

And from my intuition, the problem may root from ssh_config, e.g. the Host or Mach block failed to match the host.


(Josh Batchelor) #8

Circling back to this. I manually added entries but I'm not seeing them added to any of the config files. Also when I add a test entry to "/Users/me/Library/Group Containers/E78WKS7W4U.io.coressh.ssh/.ssh/config" it never shows in the UI.


(Yang.Y) #9

The host configured in ssh_config never appears in Core Shell automatically. You have to create a host in Core Shell manually, with the address matches the entry in ssh_config, then Core Shell would load matched options from configure file.

In other words, ssh_config is a centralized source of ssh configuration, not a source of host list.