Not Responding issues

OS: 10.15.7

Everything went fine when I created my first connection yesterday, but I am now trying to create a second one today and the window keeps freezing for over a minute after I enter anything in any of the fields and moving to another one. With patience, I managed to enter all the information needed to create my tunnels for that connection, but pressing Create freezes the app for good and it never recovers from Not Responding.

Hi Jean, thank you for the feedback, I'm sorry about the problem. Are you using Core Tunnel version 2.5? You can find the version number from main menu *Core Tunnel -> About Core Tunnel".


Yes I am using 2.5.

Great product idea by the way, very niche but very effective, it will save me a lot of time.

I'm investigating this issue, will update this thread once I catch the root cause.


Hi Jean, are you able to reproduce the issue? I ran Core Tunnel on exactly the same version of macOS (i.e. 10.15.7), but unfortunately could not reproduce the issue.

Kindly Regards,


Hello! I'm experiencing the exact same issue. I've attached a process sample as well.

To reproduce:

macOS 10.15.6
Core Tunnel 2.5

  1. Clone or Create a new tunnel
  2. Try to edit tunnel name or anything in input fields
  3. App starts freezing and eats 99% of CPU

So I'm not able to add more than 1 tunnel at this point...


Sample of Core Tunnel.txt (272.4 KB)

Hi Alexander, thank you very much for the sample!

Weird enough, still could not reproduce it. Do you have iCloud sync enabled? Is this issue always reproducible?



Nope, my macOS setup is pretty barebones, I have almost every Apple service banned in Little Snitch and pf, never used iCloud and mostly live in iterm2 =)

Yes, the issue is reproducible and it surely has something to do with "tunnel name" input field, since CPU load occurs only when the input field is focused and one is trying to type something.

Just tested, and it's still there.

The algo is the same

  1. Create new or duplicate a tunnel
  2. Edit IP address, anything — FINE
  3. Edit tunnel name — instant CPU hog

I've created a screen recording to show this behaviour =)

@Alexander_Saar Thank you so much for the hint.

Though I still could not reproduce the issue, but from what you described, I guess it's related to verification of descriptive name.

I build a hotfix release with verification disabled, could you please download it and give it a try?




And it really helped straighten this out. Tried editing, cloning, editing more descriptions, CPU load was acceptable all the times =)

Thanks for the hotfix, I'll keep an eye if this bug reappears somewhere.

Thanks a lot for your feedback, will make a public release ASAP.



I've noticed a new issue after this hotfix:

Every time a tunnel reconnects it's asking for ssh fingerprint verification (I have to manually input "yes" every time.

@Alexander_Saar The hotfix version 2.5.1 is public released, please upgrade to this official release, let me know if this version still could remember your ssh fingerprint.


@yang And it's fixed now.