LC_CTYPE warning after enable PWD reporting

Hi!

I've got the same problem. Since I configured the remote system to load .bashrc_Core_Shell I'm getting the line:

-bash: warning: setlocale: LC_CTYPE: cannot change locale (UTF-8): No such file or directory

after I run every command

This happens both when I connect with Core Shell, or with plain ssh

I've commented out the lines in ~/Library/Group\ Containers/E78WKS7W4U.io.coressh.ssh/.ssh/config as per the instructions above. Also I've updated the remote .bash_profile to check for (and load) .bashrc

When I rename .bash_profile to something else, the issue goes away - given that the only content on the file is the loader for the Core Shell script and the call to .bashrc, I guess the issue is related to the "notification" script

Thanks!

What is more "curious" is that after "disabling" the script (renaming .bash_profile) and logging back into the remote host, the "download/upload" feature is not working, as expected -- but the window title is showing the remote path correctly!!

Do you have Core Helper enabled? Do you mind paste contents of your .bash_profile and .bashrc here, or send me personal message?

but the window title is showing the remote path correctly!!

Some linux boxes handle working directory as in macOS Terminal.app, .bashrc_Core_Shell reports $PWD but won't show it in title.

Hi,

Finally could find some time to loop back into this.

Attaching the files requested. This is an AWS Ubuntu host, and as far as I can remember, there's been no changes from the default .bashrc

(adding the content of the file as I don't see how to attach them):


.bash_profile:

[[ -n "$SSH_TTY" || -n "$SSH_CONNECTION" ]] && [ -r "$HOME/.bashrc_Core_Shell" ] && . "$HOME/.bashrc_Core_Shell"
[ -r "$HOME/.bashrc" ] && . "$HOME/.bashrc"

.bashrc:

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
case $- in
    *i*) ;;
      *) return;;
esac

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options
HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# If set, the pattern "**" used in a pathname expansion context will
# match all files and zero or more directories and subdirectories.
#shopt -s globstar

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "${debian_chroot:-}" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
	# We have color support; assume it's compliant with Ecma-48
	# (ISO/IEC-6429). (Lack of such support is extremely rare, and such
	# a case would tend to support setf rather than setaf.)
	color_prompt=yes
    else
	color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[e[01;32m\]\u@\h\[e[00m\]:\[e[01;34m\]\w\[e[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \wa\]$PS1"
    ;;
*)
    ;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'
fi

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# Add an "alert" alias for long running commands.  Use like so:
#   sleep 10; alert
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
    . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
  fi
fi

Could you please follow guide in Troubleshooting section of this topic?

It's very likely caused by ~/.bashrc was not executed.

Hi,

I had found that topic when I looked at it before, and already had the line [ -r "$HOME/.bashrc" ] && . "$HOME/.bashrc" as part of my .bash_profile (see my previous post).

Now I've changed it to be at the beginning of the file in case it makes any difference; so my .bash_profile is now:

[ -r "$HOME/.bashrc" ] && . "$HOME/.bashrc"
[[ -n "$SSH_TTY" || -n "$SSH_CONNECTION" ]] && [ -r "$HOME/.bashrc_Core_Shell" ] && . "$HOME/.bashrc_Core_Shell"

I've updated an alias in .bashrc and I see the change working so the file is read on login.... but I still see the -bash: warning: setlocale: LC_CTYPE: cannot change locale (UTF-8) error

Thanks!

Could you please add following lines to the very beginning of ~/.bash_profile?

export LC_ALL=en_US.UTF-8
export LANG=en_US.UTF-8

Hi!

I've tried your suggestion, but it doesn't seem to help:

ubuntu@jjdemo:~$ echo $LC_ALL
en_US.UTF-8
-bash: warning: setlocale: LC_CTYPE: cannot change locale (UTF-8)
ubuntu@jjdemo:~$ echo $LANG
en_US.UTF-8
-bash: warning: setlocale: LC_CTYPE: cannot change locale (UTF-8)
ubuntu@jjdemo:~$ head -15 .bashrc
# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
case $- in
    *i*) ;;
      *) return;;
esac

export LC_ALL=en_US.UTF-8
export LANG=en_US.UTF-8

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options
-bash: warning: setlocale: LC_CTYPE: cannot change locale (UTF-8)

I've logged-off and logged-in a couple of times for good measure, but the issue is the same...

Hi, sorry for the delay. We recently release an update, and added a new setting relates to the locale:

Could you please do the upgrade, and uncheck "International" option in host settings?

Thank you,

BTW, don't forget remove the lines you have added to your remote ~/.bash_profile:

export LC_ALL=en_US.UTF-8
export LANG=en_US.UTF-8