How to use password protected private key

improvement

(Jakob Larsen) #1

I am trying out Core Tunnel for first time, so I may be missing something obvious here. When trying to create the tunnel I always get this error

Load key “/Users/***/.ssh/id_rsa”: Operation not permitted

I am guessing that this is related to the fact that my private key is password protected, so I need to enter a password to enable usage of the private file. I don’t get this option meaning that my private key is not possible to be used.

Am I missing something here or is there a way to give Core Tunnel access to use private key?


(Yang.Y) #2

No, the error indicates Core Tunnel has no permission to load your private key. You must install the XPC component as explained here:


(Jakob Larsen) #3

Thanks this works.
You may have an edge case error somewhere, as I was never prompted for the XPC component even though I set up the connection to use my system private key. Setting it up from the locations tab worked just fine and with XPC all worked as expected.


(Yang.Y) #4

Thanks for reminding.

OpenSSH always tries to load key ~/.ssh/id_rsa by default, even though it has no permission under sandboxed environment.

We can prompt user for the XPC component, but App Store Review team would reject the app unless the alert window is triggered by users explicitly (e.g. changing preferences or tunnel settings).

It still has some room for improvement, we will make log message guidable in future update, help users understand the problem and find the solution much easier.


(Yang.Y) #5