Dynamic port forward and Firefox proxy


#1

I had a dynamic tunnel setup in ssh tunnel to an AWS ec2 instance. Had Firefox manual proxy configured to 127.0.0.1 on custom port. This had worked on ssh tunnel ever since I got it installed.

Same configuration on core tunnel and Firefox comes up with “The connection was reset” error. I’ve messed with different config parameters, defaults, etc. No luck.

Any idea what i’m missing and can someone try on their ec2 instance and see if they can reproduce the issue to help narrow down what i’m doing wrong?

/Noak


(Yang.Y) #2

Could you please paste a screenshot of your Firefox proxy setting?


#3

Firefox proxy settings


(Yang.Y) #4

You should use SOCKS v5 instead, Core Tunnel does not support HTTP proxy, I just wrote a post about how to use dynamic port forwarding:


#5

@Yanks, the issue has been resolved. So you need to set the system SOCKv5 proxy and manually configure Firefox to “Use system proxy settings”.

The post you shared is what I used to get the system proxy settings setup.

/Noak


(Yang.Y) #6

You can set Firefox to use SOCKS v5 proxy if you prefer to leave other apps not proxied. Set system proxy settings would cause apps like Mail.app, Safari.app and iTunes.app etc. redirect their traffic over the proxy.