Crash Report

Hi Yang.

Just had a crash. Report attached
CoreShell Crash Report.txt (109.6 KB)
, hope it helps.

Kind regards,


Hi Jonathan, thank you for the crash, will investigate this issue.

BTW: do you have reproduce steps? Which executable were you using when you experienced the crash issue?



My workflow is CodeRunner-GitHub Desktop-CoreShell-Safari- and repeat. I think it was CodeRunner.


Core Shell_2021-10-07-225806_MM-GAR-M1-8.crash (105.1 KB)
as well some other crash without any user interaction (it crashed in the background - window just vanished while working on something else)

1 Like

anther crash while using crontab -e (implementing vim)
Core Shell_2021-10-14-012933_MM-GAR-M1-8.crash (103.6 KB)

Thank you Alex, I'm investigating this issue.


Core Shell_2021-10-17-152523_MM-GAR-M1-8.crash (105.2 KB)
while trying to start vim

@jonathangroves @alexbartl sorry to have waited a long time, the first beta of Core Shell 3.6 has just been released, this issue should be fixed in this release. Could you please download and test it when you get a chance?

Thank you very much,


1 Like

io.coressh.openssh_2021-10-25-094837_NBAM1-ALX.crash (61.7 KB)
io.coressh.openssh_2021-10-25-094837-1_NBAM1-ALX.crash (61.9 KB)
io.coressh.openssh_2021-10-25-094837-2_NBAM1-ALX.crash (62.7 KB)
io.coressh.openssh_2021-10-25-095338_NBAM1-ALX.crash (63.4 KB)
io.coressh.openssh_2021-10-25-095338-1_NBAM1-ALX.crash (62.5 KB)

not that stable yet, hanged (seems to loop) while using vim and had to bee killed

io.coressh.openssh_2021-10-24-134825_MM-STA-M1-8.crash (61.6 KB)
io.coressh.openssh_2021-10-24-134830_MM-STA-M1-8.crash (61.5 KB)

same here from yesterday, maybe needs to catch that one, so at least it is not hanging

I don't have reproducible conditions for my crash so no value in me testing it, sorry.

Host key mismatch not correctly reported in BETA Version (see the differences):

08:19:13 Connecting…
08:19:13 Using Core Helper 6.5 (r3350)
08:19:13 The OpenSSH process terminated unexpectedly.
08:19:13 Abnormal Disconnect
08:19:13 Connection failed, retry after 3s…
08:19:15 Disconnected

08:19:02 Connecting…
08:19:02 Using Core Helper 6.2 (r3342)
08:19:02 Authenticating…
08:19:02 @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
08:19:02 @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
08:19:02 Someone could be eavesdropping on you right now (man-in-the-middle attack)!
08:19:02 It is also possible that a host key has just been changed.
08:19:02 The fingerprint for the ECDSA key sent by the remote host is
08:19:02 Please contact your system administrator.
08:19:02 Add correct host key in /Users/alex/.ssh/known_hosts to get rid of this message.
08:19:02 Offending ECDSA key in /Users/alex/.ssh/known_hosts:30
08:19:02 ECDSA host key for []:24 has changed and you have requested strict checking.
08:19:02 Host key verification failed.
08:19:02 Abnormal Disconnect

Hmm, maybe some other issue, BETA version still not connecting (same error message), even after removing the old host key

Thank you very much Alex, I'm working on these issues, will release next Beta tomorrow.


no rush, take your time, thank you!

@alexbartl the second beta is ready, please give this beta binary a try when you get a chance.

Thanks a lot,


The "I do not want to connect" problem is history, and since, no single crash, even not after wakeup, so far. (V 3.6-beta.2)

Hmm, reported too early, just hung while having vim open and loosing the network connection (tunnel went down). Connection came back, but Beta version did not, still hung and had to be killed.

Beta.crash (1.9 MB)

Alex, thank you for following up.

Is this issue always reproducible? Could you please send me a copy of exported JSON file of the problematic profile? And, are there any other settings in your ~/.ssh/config for this host?

Kindly Regards,


Hi Alex,

Though I still could not reproduce this issue, but according to your bug reports, and after a code review, I believe this issue is fixed in Core Shell 3.6 Beta 3. Please give it a try when you get a chance.

Thank you very much,


I could not reproduce it either, nor any more crashes yet, so switching to Beta3 now, will report here

So far, no crashes on Beta3.

1 Like