Back to Codinn

Core Tunnel 1.2 update is broken - help


(Mike Rubin) #1

I updated to Core Tunnel 1.2 today. Installed the Core Helper Installer. Whenever I try to connect to a tunnel, I get the below:

12:10:26 Connecting…
12:10:26 Authenticating…
12:10:30 Failed to add the host to the list of known hosts (/Users/redacted/.ssh/known_hosts).
12:10:30 Load key “/Users/redacted/.ssh/id_rsa”: Operation not permitted
12:10:30 Permission denied (publickey).
12:10:30 Abnormal Disconnect


(Yang.Y) #2

I’ve reproduced the bug, and please use this hot-fix version temporarily:

Core Tunnel.1.2-hotfix

Will push it to App Store ASAP.

Thanks for reporting!


(Yang.Y) #3

The hot-fix release (version 1.2.1) has arrived in Mac App Store, please do the upgrade.

Sorry for the glitch!


(Norman Saade) #4

I downloaded the new version (1.2.1) from the Mac App Store and installed Core Helper.
Unfortunately, I am still seeing this error:
11:46:25 Authenticating…
11:46:25 Load key “/Users/Norman/.ssh/id_rsa”: Operation not permitted
11:46:27 Permission denied, please try again.
11:46:34 Permission denied, please try again.
11:46:41 Permission denied (publickey,password).
11:46:41 Abnormal Disconnect

Password is correct since I can ssh from terminal with the passphrase.
Already tried reinstalling core tunnel together with Core Helper completely but still no luck.
(In the pervious version it worked with the XPC Helper)
Any suggestions?


(Yang.Y) #5

Have you enabled system config?


(Norman Saade) #6

Thank you for the quick answer but there seems to be an other bug: Changes in the preferences/location tab don’t seem to get persisted. When I close preferences and open the tab again it is back to “Default”.


(Yang.Y) #7

Could please reboot your Mac and check the options again? I got a similar issue report, and a system reboot fixed that issue.


(Norman Saade) #8

That worked. Thank you …