Core Shell SSH download creates the file name but doesn't download

Hi again @dnowhere.

That's very strange. I'm sure @yang will know the answer.

I did find one reference to a vaguely similar problem (not involving Core Shell) where it was suggested that rebooting the server solved it - at least temporarily. If you're able to eliminate this I guess it could help.

Sorry - I'm not being of much assistance.

I'll be interested to see what turns out to be the cause.

Keep safe.


Thank you. When I clicked on the arrow keys at the top right (for downloads and uploads), I noticed that all of my downloads have a connection closed error. I tried uploading and ended up with the same error.

I’m trying this on a Synology NAS and I can’t think of why it’s happening. I mean I’m already in with sudo -i

Hehe - I didn't realise the two little arrows were a button before! I only ever noticed them wibbling when a download was taking place.

How are you initiating the download? I do an ls to get the directory listing, highlight the filename with the trackpad cursor, click with two fingers and choose "Download". Wondering if you're doing something different?


Just noticed the arrows a while ago too :slight_smile:

That’s what I’m doing, highlighting the file, two fingers and choosing download. I’ve even ran “enable quick download”.

Do I need to enable SFTP on the server?
I read the feature announcement on the blog somewhere here and it didn’t say anything about that.

I’ve restarted the server, BTW (it’s a VM), still the same.

While you download and/or upload file, a standalone SFTP task is created based on your host configuration, so yes, you have to enable SFTP on the server.

Kindly Regards,


Thank for your input @yang. This occurred to me and I tried enabling it. Strangely the error changed to file can’t be found (instead of connection closed).

Do I need to set the SFTP port somewhere. When I enabled it (on the server), I gave it the same port number as SSH and that’s when I got the “file cannot be found” message.

Keep it the same port as SSH is fine.

Could you please give this a try? Download a file in your HOME directory, then see if it prompts the same error message.

Kindly Regards,



Tried it. Same message. Even tried a different Synology server that I have. Same.
I’m accessing both servers locally over Ethernet using their IP addresses.

Could it be something to do with Big Sur? I’ll try to test with an older Mac and see when I have the chance.

Big Sur has no issues upload or download to my linux hosts in the cloud.


The error was from the remote side, so it couldn't be related to Big Sur.

Could you please test with raw sftp command in local terminal?

First login to the remote host with sftp command, then use put and get subcommands to upload and download file.

If it print the same error messages, then the problem is rest in configuration of the remote side.

Kindly Regards,


Thank you for confirming that. Appreciated.

Will try try to test that over the weekend. Thanks.

Came back to say that using ForkLift 3 (Binarynights), connected to the server with SFTP, I can drag and drop any file to my MBA without any problems. It downloads correctly.

I’ll try your suggestion later and report back when I can. Thanks.

Hi @yang

Managed to try sftp from terminal and I’ve been able to “get” and “put” successfully multiple times. The files were intact and readable whether dloaded or uploaded.

Being able to use standard terminal sftp commands successfully in addition to having no problems with ForkLift means that it has something to do with Core Shell. Maybe the way it implements this functionality does not agree with my Synology DiskStations :slight_smile:

Thank you so much for helping investigate this issue, there might be something wrong in Core Shell's SFTP component.

The next version of Core Shell is coming, this version can reveal detailed connection log for up/download tasks. I'll send you a beta test version before public release, we may find out the real cause.

Kindly Regards,



We have launched Core Apps Beta Program, Core Shell 3 beta now can reveal detailed connection log for up/download tasks.

Could you please give the beta version a try, and attach the desensitized log file?

Three steps to get a connection log:

  1. Edit the profile, and set Log Level to Debug3.
  2. Log into the server, and download the file that was proven problematic.
  3. Click transfer list icon on top-right, then right click on the failed downloading task, select Reveal Logs from the context menu.

Thank you,


I'm facing the same problem, and the problem is security. Check the logs:

2022/03/01 07:38:04:146  Changing to: /home/user/.
sftp> get -R "/etc/letsencrypt/live/" "/Users/MacUser/Downloads/Cert-Windows.pfx (3).coredown"
2022/03/01 07:38:04:151  debug1: Couldn't stat remote file: Permission denied
2022/03/01 07:38:04:151  File "/etc/letsencrypt/live/" not found.

What should we do?

It seemed the logon user does not have permission to access file /etc/letsencrypt/live/, please try copy it to user home then download it again:

sudo cp /etc/letsencrypt/live/ ~/
cd ~/
ls Cert-Windows.pfx


thank you for your return. Yes, that is what I did to make it to work, but I need to do every single time that I need to work with a file/folder that the owner is root.
Can the download/upload run with sudo ?

Core Shell creates SFTP tasks for download/ upload operations, it is not possible to do sudo in SFTP.

Kindly Regards,