Core Helper does not stay loaded

I am running CoreShell on an M1 Mac mini. Whenever I re-boot, the Core Helper needs to be reloaded. I have been able to work around this issue by running Core Helper Installer as a startup item, but it would be nice not to have to do this.

This problem occurred under MacOS 11 and still happens in the MacOS 12 beta.

I have tried explicitly uninstalling Core Helper using the instructions on the web site, and specifically enabling it in launchctl without success.

The launchd.log file has:

2021-06-11 15:26:58.993283 (gui/501 [100006]) : Bootstrap by otherbsd[438] for /Volumes/ExternalSSD/craig/Library/LaunchAgents/ failed (122: Path had bad ownership/permissions)

But I don’t see anything obviously wrong with either the path or the permissions.

It seems your macOS Big Sur resident on a external SSD driver, could you please check if the mounted disk has the "Ignore ownership on this volume" box unticked?


BTW, I found a similar bug report of Facebook watchman at here:


Thank You, that fixed it.