Copy text using trackpad - issues


(Jonathan Groves) #1

Sometimes, when I copy text in Core Shell using the trackpad, then paste elsewhere in Core Shell, I get whitespace pasted at the end of each line. I can reduce the whitespace by reducing the terminal window width when I copy - and (bizarrely) it only happens sometimes.

It is really annoying - when I know I have much copying and pasting to do I use one of your competitor's products and it makes me feel dirty!

Thanks for listening.


(Bart Busschots) #2

I just want to flag how much I agree with this being a really big annoyance.

I simply can't copy-and-paste from things like vi when they are running in Core Shell without getting all that white space. The same was not true with CoreSSH, nor is it true when I SSH from the Terminal. It's just Core Shell that behaves like this.


(Jonathan Groves) #3

vi? Hardcore! I've tried and tried to learn the commands but always end up back in nano lol


(Yang.Y) #4

Thanks a lot for the complain, I acknowledge this is a known issue.

Could you please give me repro steps? So that I can confirm we're talking about the exact same problem.


(Jonathan Groves) #5

I'll do this as soon as I get time, but probably not before Friday afternoon, sorry. Busy busy.


(Yang.Y) #6

Thank you, I'll waiting.

@bart.busschots Do you have time to give me a repro steps? Thank you.


(Jonathan Groves) #7

Hi.

  1. Download this file: https://www.dropbox.com/s/agnkm8aau9mv02i/example.py?dl=0
  2. Put onto a machine you can SSH into.
  3. Open in nano.
  4. Highlight all the code by tap-dragging with touchpad.
  5. Move cursor to bottom of file with cursor keys.
  6. Cmd-V to paste.
  7. All pasted lines have whitespace at the end.

Hope this helps!


(Yang.Y) #8

Thanks a lot for the steps, will try to fix it ASAP.


(Yang.Y) #10

Yes, sure, as I've said, it's a known issue :slight_smile:


(Bart Busschots) #11

Sorry I wasn't able to get back to you until now.

You have steps already, but in case it's helpful, I run into this issue with vi rather than nano/pico, and it's very easy to reproduce:

  1. SSH into any Linux machine
  2. cat /etc/hosts > demo.txt; vi demo.txt
  3. Drag to select the text, copy
  4. Paste into text editor of choice and notice all the white space
  5. :q to exit vi, then optionally rm demo.txt to clean up

I also hit this bug with other commands, but not all commands, for example, selecting multiple lines of output form ls -1 does not result in trailing white space in the clipboard.


(Yang.Y) #12

Thank you Bart, will try to fix it in next update.