Can not import private key to Identity container

MacOS Sonoma 14.5 (23F79)

I go to Core tunel - settings - Identity - '+' - Import private keys - choose it - ok - it appears in folder "~/Library/Group Containers/E78WKS7W4U.io.coressh.ssh/.ssh/config/privatekey". Then I go to existing tunnel or create a new tunnel - settings - Connection - want to choose my private key but I can not because I see only "config" file in that list. If I click "select" and choose my private key then it creates a new private key in the same folder with name (2), but still I can not choose a private key.


This is a screenshot of identity container. It does not show private keys.

Hi Andrey, where is your private key locate?

To import your private key:

  1. Navigate to Settings > Identity
  2. Click + button and select Import Private Keys, a dialog prompts you to select your private key
  3. In the file open dialog, navigate to the directory of your private key. The private key default location is ~/.ssh/id_rsa.

Let me know if you need further assistance.

Kindly Regards,

Yang

After importing a private key from a default directory ( ~/.ssh/) in the "Identity" menu, private keys are not displayed in the list (above second screenshot). Even when I try to create a new tunnel, my added private key is not displayed in the “Private Key” item(above first screenshot).
This problem appeared after update.

1 Like

Thank you so much for the patient explanations. Yes, it obviously a bug.

I'll make a hotfix release ASAP.

Thanks again,

Yang

1 Like

Hotfix version 3.8.9 is available for upgrade, thank you again for helping.

Kindly Regards,

Yang