.bashrc_Core_Shell problems


(Alex Currie Clark) #1

When enabling "Reporting Current Working Directory" I encountered 2 issues.

Firstly, when the command was run, the "c" of "curl" was missing. The command "url" was naturally unavailable.

url -fsSL https://raw.githubusercontent.com/codinn/core-shell-...
^ missing c

Secondly, my bash setup is loaded via a .bashrc file, not .bash_profile. This meant that my profile was now being ignored on login. To overcome this, I had to add a call to .bashrc to the new .bash_profile file.


(Yang.Y) #2

the "c" of "curl" was missing

Thanks a lot for reporting the issue, I'll try to reproduce it.

Secondly, my bash setup is loaded via a .bashrc file, not .bash_profile

The .bashrc or .bash_profile is loaded exclusively, please go to Troubleshooting section of this post:

Maybe a better solution is on the basis of the existence of .bashrc and .bash_profile files to determine where to load the .bashrc_Core_Shell from, I'll investigate.


(Alex Currie Clark) #3

Thanks for this. My apologies for missing the Troubleshooting section.

One further point. I initially went to download a file from my server, but the "Download" option was always greyed out. I know now that this was because I needed to apply the .bashrc_Core_Shell script. However, to trigger this, I had to first try to upload a file.

It could perhaps be made clearer (in the app, rather than the FAQ) that this step is necessary?


(Yang.Y) #4

Another way to trigger the script installation is Shell > Enable Reporting Current Working Directory in main menu. I've update the post, thanks for reminding :grinning:


(Alex Currie Clark) #5

You are most welcome. Thanks for the swift response.