Abnormal Disconnect (suddenly)

All my hosts suddenly stopped working (it wont connect) with an error message reading "Abnormal Disconnect".

When I realized I was able to SSH just fine via terminal I started going down the rabit hole. Here is what the log file says:

Equivalent Command: ssh -i "/Users/*****/Library/Group Containers/E78WKS7W4U.io.coressh.ssh/.ssh/privatekey/*****" -vvv -o ServerAliveInterval=15 -o ServerAliveCountMax=3 -o ExitOnForwardFailure=yes -p 22 @**
17:24:39 Connecting…
17:24:39 The OpenSSH process terminated unexpectedly.
17:24:39 Abnormal Disconnect
17:24:39 Connection failed, retry after 3s…

I read on another thread about Core Helper, so I decided to give it a try, installed it and boom, it began working again.

So I am guessing something is broken in the OpenSSH implementation of the app and it happened during the weekend because I was logged in just fine last friday.

Appreciate any direction as I am guessing I shouldn't need to rely on Core Helper to get things running.

1 Like

Hi Jose,

Could you please run this command in local shell:

ssh -i "/Users/*****/Library/Group Containers/E78WKS7W4U.io.coressh.ssh/.ssh/privatekey/*****" -vvv -o ServerAliveInterval=15 -o ServerAliveCountMax=3 -o ExitOnForwardFailure=yes -p 22 @**

and then send me a copy desensitized copy of terminal output?

Kindly Regards,


I have had this issue a few times recently - "Abnormal disconnect" with all Linux hosts. To fix, this is what I do:

  1. Disable Core Helper (Preferences>Advanced>Uncheck "Enable Core Helper")
  2. Run the Core Helper Installer.app again (I have not needed to re-download it)
  3. Enable Core Helper again (the opposite of Step 1)
    Then everything works as before.

Hope this helps.

Kind regards, keep safe...


What is the macOS version? And, could you please search for keyword "coressh" in Console.app when you encounter "Abnormal disconnect" issue?

Kindly Regards,


Ventura 13.4.1 (22F82) on Intel silicon.

Will do – I’ll post back when it happens again.

Kind regards, keep safe.


Hi @yang

It just happened again. No mention of coressh anywhere in Console app.

Ran the Core Helper Installer app again and it worked immediately I started Core Shell again.

I'm sure it's not relevant but I did have VSCode running with two open connections to the same machine I was trying to connect to with Core Shell. But Core Shell connected fine after installing the Core Helper with VSCode still running.

Please let me know if there is anything else I can do to help understand this.

Kind regards, keep safe...


It seemed Core Helper agent exited accidentally.

When the next time you run into "Abnormal disconnect" issue, please first run

ps aux | grep coressh

in Terminal.app, and you should get output like this:

yang              4010   0.0  0.0 408543520   3360   ??  S     5:31PM   0:00.02 E78WKS7W4U.io.coressh.ShellHelper
yang              4745   0.0  0.0 407962720     48 s014  R+    6:07PM   0:00.00 grep coressh
yang              4542   0.0  0.1 409509264  15840   ??  S     6:04PM   0:00.05 /Users/yang/Library/Group Containers/E78WKS7W4U.io.coressh/io.coressh.Helper.app/Contents/MacOS/io.coressh.Helper

But if it prints:

yang              4745   0.0  0.0 407962720     48 s014  R+    6:07PM   0:00.00 grep coressh

It indicates Core Helper agent exited for various reasons (killed or abnormal exit). For this case, instead of reinstall Core Helper, try run this command to load Core Helper agent again:

launchctl load ~/Library/LaunchAgents/E78WKS7W4U.io.coressh.helper.plist

And then execute ps again:

ps aux | grep coressh

You should see three items printed.

Also, could you please Enable logging and paste the desensitized output?

Kindly Regards,


jonathangroves@Jonathans-MacBook-Pro ~ % ps aux | grep coressh
jonathangroves   43940   0.0  0.0 33591680     76 s000  R+    5:07pm   0:00.00 grep coressh
jonathangroves   43898   0.0  0.0 34154344   4712 s002  Ss+   5:06pm   0:00.02 /Users/jonathangroves/Library/Group Containers/E78WKS7W4U.io.coressh/io.coressh.Helper.app/Contents/MacOS/io.coressh.openssh ssh E78WKS7W4U.io.coressh.helper
jonathangroves   43827   0.0  0.0 34172776   6008 s001  Ss+   5:05pm   0:00.08 /Users/jonathangroves/Library/Group Containers/E78WKS7W4U.io.coressh/io.coressh.Helper.app/Contents/MacOS/io.coressh.openssh ssh E78WKS7W4U.io.coressh.helper
jonathangroves   43543   0.0  0.0 34168864   4348   ??  S     5:00pm   0:00.06 /Users/jonathangroves/Library/Group Containers/E78WKS7W4U.io.coressh/io.coressh.Helper.app/Contents/MacOS/io.coressh.Helper
jonathangroves   43538   0.0  0.0 34159664   3568   ??  S     5:00pm   0:00.02 E78WKS7W4U.io.coressh.ShellHelper
jonathangroves@Jonathans-MacBook-Pro ~ % 
Equivalent Command: ssh -4 -vvv -o AddKeysToAgent=yes -o ServerAliveCountMax=3 -o ExitOnForwardFailure=yes -o ServerAliveInterval=15 -p 22 jonathan@
16:11:06 Connecting…
16:11:06 Using Core Helper 6.6 (r3386)
16:11:06 OpenSSH_8.8p1, OpenSSL 1.1.1l  24 Aug 2021
16:11:06 debug1: Reading configuration data /Users/jonathangroves/.ssh/config
16:11:06 debug1: Reading configuration data /etc/ssh/ssh_config
16:11:06 debug1: /etc/ssh/ssh_config line 21: include /etc/ssh/ssh_config.d/* matched no files
16:11:06 debug1: /etc/ssh/ssh_config line 54: Applying options for *
16:11:06 debug2: resolve_canonicalize: hostname is address
16:11:06 debug3: expanded UserKnownHostsFile '~/.ssh/known_hosts' -> '/Users/jonathangroves/.ssh/known_hosts'
16:11:06 debug3: expanded UserKnownHostsFile '~/.ssh/known_hosts2' -> '/Users/jonathangroves/.ssh/known_hosts2'
16:11:06 debug3: ssh_connect_direct: entering
16:11:06 debug1: Connecting to [] port 22.
16:11:06 debug3: set_sock_tos: set socket 3 IP_TOS 0x48

Tried the launctl...

jonathangroves@Jonathans-MacBook-Pro ~ % launchctl load ~/Library/LaunchAgents/E78WKS7W4U.io.coressh.helper.plist
Load failed: 5: Input/output error
Try running `launchctl bootstrap` as root for richer errors.
jonathangroves@Jonathans-MacBook-Pro ~ % 

Oh no - this isn't the same problem. Remove Core Helper and added it again and same problem present.

Please try unload and then load again:

launchctl unload ~/Library/LaunchAgents/E78WKS7W4U.io.coressh.helper.plist
launchctl load ~/Library/LaunchAgents/E78WKS7W4U.io.coressh.helper.plist