2.0 is completely broken on Mac with file sync enabled

2.0 is completely broken on two macs here running 10.15.4. It worked briefly when suddenly all windows disappeared and now it will not launch at all. Did complete uninstall and re-installs. Rebooted as well. I was using Folder sync and it has been rock solid for years. Using Visual Studio Code now...actually pretty good with the Remote Development extension installed...

New version installed this morning. This is all I get. Blank windows stacked...

Version is 2.0.1

That is SO sad :frowning_face:

Did you complete uninstall by using 3rd party apps like CleanMyMac?

When the blank windows shows, was Sync function enabled or disabled?

I did a complete uninstall with AppCleaner. Then a reboot. Same thing on two macs but now after killing the app with the stacked blank windows several times it came back and it looks like it's working properly. Will do some more tests though. Odd thing is that my private keys don't show in the app but at least one of the connections depending on a private key connected...

Folder sync was enabled the whole time.

App still crashes on my MBPr.

coreshellcrash.zip (27.3 KB)

It seems your synced data was corrupted by release 2.0, I will build a revised version for you to fix the data.

Hi Mikael, please download this revised binary Core Shell-2.0.2 and run it on both of your Mac machines, try restore purchases and reenable file sync, and your corrupted data should be fixed.

And if everything works for you, I'll release it on App Store as well as Setapp.

Thank you

Since I've reproduced the issue, and also verified that the corrupted data is repaired by revised binary.

So instead of waiting your feedback, I decided to release it directly to reduce downtime for other users.

Thank you so much for providing the crash log!

I can run it on both macs and my hosts all show up but I can't restore purchases so I can't configure sync settings. I get this dialog when I try,




1 Like

Mikael, I didn't expect you so responsive :smiley: thank you for testing, and I've pushed it to App Store, should be available for upgrade within a couple of days.



Thank you very much, version 2.0.2 seems to fix the problem, although I get the same error message as Mikael, which will be pretty likely gone, once it is in the app store. I will just wait for that to be able to reenable the sync.

However I have one MacBookPro where I could get it fixed with Version 2.0.1 but unfortunately I have no clue what caused the fix (including sync enabled)

@mikael.fransson @alexbartl version 2.0.2 is available for upgrade on App Store, thank you very much for helping!

Aa expected, purchases can be restored now, thank you!

1 Like