Can't login remote server when using default port 22

Please improve handle default port logic.

I have two entry in my ~/.ssh/config

# Config for Gerrit Code Review
    User my
    Port 29418
    IdentityFile ~/.ssh/id_ed25519

# Config for Gerrit Admin
Host gerrit-admin
    User gerrit
    Port 22
    IdentityFile ~/.ssh/id_ed25519

I can use the command ssh gerrit-admin or ssh -i ~/.ssh/id_ed25519 -p 22 to login the site.

The issuse is when create a Profile in Core Shell

General -> Host:
General -> Port: 22
General -> User: gerrit
Advanced -> IdentityFile: ~/.ssh/id_ed25519

Equivalent Command which ignored the port 22 which will be affect by config in ~/.ssh/config

Equivalent Command: ssh -i ~/.ssh/id_ed25519 -o ExitOnForwardFailure=yes -o ServerAliveCountMax=3 -o ServerAliveInterval=15

So, Please add -p 22 parameter to force use the port in Core Shell General Tab.

Currently Solution is use Host alias in Core Shell General Tab

General -> Host: gerrit-admin
General -> Port: 22
General -> User: gerrit
Advanced -> IdentityFile: ~/.ssh/id_ed25519

Thanks a lot for point out this problem, will fix this in next update.

Kindly Regards,


Core Shell 3.6 Beta 3 now always explicitly specify the port number to connect on the remote host.

Please give it a try when you get a chance.

Thank you again,


Thanks, It works.

Core Shell 3.6
Release Date: 2021-11-11

1 Like